Mi Band rejected connection

Hi there,
I tried to sync my Mi Band 3 yesterday and the app told me "Mi Band rejected connection, retrying in a few seconds".
Nothing happens. Last sync was on 8/8/2018. Probably I did a firmware on that day. I dont remember.

How to get connection back?

I havent had the Mi Fit app installed for months. I never used any other app to sync.

Comments

  • Well, just for your information:

    Nothing I tried, solved the problem. So I had to "hard reset" my Mi Band 3 by letting it run out of battery. While charging, the Mi Band instantly got connection again.

    How to kill the battery? Just start the stopwatch function from "More"-menu and let it work. It takes some hours and you have to restart the stopwatch every 99:59 minutes.

  • I had the same problem but with a mi band 2, using replace with new mi band option fixed it. I gess that a factory reset with the official app would do it too.

  • Nothing I did helped.
    "Mi Band 3 rejected the connection". It is not discoverable by bluetooth, notify app nor the official mifit app.
    It happened all of a sudden, after I've been using current firmware for more than 2 months.
    I am able to add the band to the notify app, only using manual Bluetooth mac address, but it is still rejecting the connection.
    Band works well independently.
    I completely discharged the band by wearing it upside down, but it did not help.
    I will try to discharge it using the stop watch, then put it for a day in the freeze and press the button for a minute before I charge it, if that won't help I'm doomed with this band.
    This is the firmware I have (2.2.0.14 with resources v46)
    https://geekdoing.com/threads/firmware-2-2-0-14-english-bold-font.504/

Sign In or Register to comment.